We're currently experiencing issues when delivering Amazon Gift Cards through the Fulfillment API
Incident Report for Ifeelgoods
Resolved
This incident has been resolved.
Posted Jun 06, 2015 - 11:15 CEST
Monitoring
The root cause, resulting to failed redemptions using Amazon Gift Card, has been resolved.
Posted Jun 06, 2015 - 11:02 CEST
Investigating
Some redemptions creation request may fail when retrieving Amazon Gift Card
Posted Jun 06, 2015 - 02:45 CEST